I-BMW.com I-BMW.com

Welcome to the I-BMW.com forums! - You're currently viewing as a limited access guest. By joining our free member supported community, you'll gain access to post/ reply, communicate privately with other members (PM), or globally via "real time chat", respond to polls, upload photos, post classifieds etc. Membership is fast so, Register @ the Ultimate Sport Touring Portal!
Should you not receive an email with activation link, check your SPAM settings or please contact us and include the ID/ email address you registered with.

Go Back   I-BMW.com > BMW K-1200 Series Motorcycles > K1200RS/GT > "KRS/GT" Technical Q&A
User Name
Password
Home Register Gallery Classifieds FAQ Members List Calendar Donate Mark Forums Read

"KRS/GT" Technical Q&A K1200RS/GT Technical Questions/Answers

Vendor Sign Up | Want to see your name in neon blue? | Want a neat reflective sticker for your ride?!

Reply
 
Thread Tools.. Display Modes
  #1  
Old 08-14-2018, 01:27 PM
freccia freccia is offline
Entering the on-ramp
Post: 1 Thanks: 1
Thanked 0 Times in 0 Posts
 
Join Date: Aug 2018
Location: Hudson, NY United State
'98 K1200RS speedometer failure

Hi, new to this forum and this bike.

I've been scouring through posts here and elsewhere. The speedometer on my bike started intermittently failing: I'd start it up, ride, speedometer operated normally then suddenly dropped to zero, came back after a while.

Now it doesn't move from zero at all.

I've gone through what I believe are the usual diagnostics- checked the wire from the rear drive sensor- no grounds; connector is clean and solid.

Removed the sensor and didn't see anything out of order.

I know this has been addressed a number of times. Any ideas?

Thanks in advance.
Reply With Quote
  #2  
Old 08-14-2018, 01:50 PM
sailor's Avatar
sailor sailor is online now
K1200RS doctor
Post: 2,180 Thanks: 818
Thanked 1,046 Times in 574 Posts
 
Join Date: Jun 2003
Location: Montreal, QC Canada
Re: '98 K1200RS speedometer failure

Quote:
Originally Posted by freccia
Hi, new to this forum and this bike.

I've been scouring through posts here and elsewhere. The speedometer on my bike started intermittently failing: I'd start it up, ride, speedometer operated normally then suddenly dropped to zero, came back after a while.

Now it doesn't move from zero at all.

I've gone through what I believe are the usual diagnostics- checked the wire from the rear drive sensor- no grounds; connector is clean and solid.

Removed the sensor and didn't see anything out of order.

I know this has been addressed a number of times. Any ideas?

Thanks in advance.

On the 1st generation of K1200RS, having the speed sensor on top of rear drive (1998-2001 for USA market), the most common cause of speedo signal anomaly are:

(1) speed sensor wires have been damaged / cut inside the black rubber insulator. This often happens where very tight zip-ties (from rear drive to frame) have force the wiring insulator to wear over time.

(2) the speed sensor is defective: this is less common than item 1 above.

(3) There is a bad connection (power wire or ground wire) in wiring harness EITHER at speedo-sensor to harness OR maybe behind speedo (yellow wire is speed signal).

(4) the dented ring inside the rear-drive has become loose and is spinning freely. The speed sensor needs this ring to be fixed to read the up-down in dented wheel (it is a pressure fit at factory).

This can be confirmed by removing the speed sensor , thru the hole , using a long thin screw driver to feel / see if ring is rotating with wheel (and is resisting a light pressure to spin freeely).
See attached photo to see what you should look for thru the hole...

This failure is less common but expensive to fix - in isolated cases this is a sign that the cone of tapered bearing at the end (cone is pressure fit into drive case) has become loose and spun. In such case, attention should be taken to check / dump the oil - color of rear drive oil would be grayish alu deposit. This is NOT the same type of failure as the main large rear drive bearing.

If dented wheel is not tight, rear-drive needs to be opened to check if it is salvageable (pressure fit can be redone is certain cases).


(5) LAST... and very uncommon, the speedo unit itself is defective. In 16 years over 3 forums (K1200RS and K1200LT), I have never seen such a case, but it is not impossible.
__________________
~~~~~~~~~~~~~~~~~~~~~~~~~~
Jean (Montreal, CANADA)
K1200RS (2002 IceBlue/Red - 95,000 miles)
~~~~~~~~~~~~~~~~~~~~~~~~~~
K1200RS parts for sale here:
http://www.i-bmw.com/classifieds/sho...500&ppuser=144
++++++++++++++++++++++++++
Reply With Quote
The following (6) I-BMW members 'like', thank -or- are 'shouting out' to 'sailor' for this post:
  #3  
Old 08-14-2018, 01:56 PM
MoRider's Avatar
MoRider MoRider is offline
Getting up to speed
Post: 350 Thanks: 324
Thanked 150 Times in 97 Posts
 
Join Date: Dec 2013
Location: Farmington, MO USA
Re: '98 K1200RS speedometer failure

As always, spot on advice from the forum's RS expert! Well done. Hope the OP appreciates it.

Ken
Reply With Quote
  #4  
Old 08-14-2018, 01:58 PM
Flyboy's Avatar
Flyboy Flyboy is online now
(Moderator) MR. GSA Man!
Post: 13,959 Thanks: 2,362
Thanked 1,869 Times in 1,128 Posts
 
Join Date: Jun 2003
Location: NYC & Lower Hudso, NY usa
Send a message via Skype™ to Flyboy
Re: '98 K1200RS speedometer failure

I once forgot to place back one of the many ground wires to the battery and soon realized my speedo was erratic....was a quick fix once I realized the hanging cable....did you remove the battery recently?
__________________
If you want something in your life
you've never had, you'll have to do
something you've never done."

Tuono V4 1100 Factory 2016
04 k1200RS Zebra.Sold
07 R1200GSA
01-SOLD K1171RS
05 R1200GS...SOLD
06 K1200R..SOLD..so long!

Learn something or simply find entertainment on i-bmw? Then why not consider supporting us via a donation?
See the "Donate" link on the NavBar in the middle of every page! Do it now NON NEONS . Thanks!
Reply With Quote
  #5  
Old 08-14-2018, 02:16 PM
sailor's Avatar
sailor sailor is online now
K1200RS doctor
Post: 2,180 Thanks: 818
Thanked 1,046 Times in 574 Posts
 
Join Date: Jun 2003
Location: Montreal, QC Canada
Re: '98 K1200RS speedometer failure

Quote:
Originally Posted by Flyboy
I once forgot to place back one of the many ground wires to the battery and soon realized my speedo was erratic....was a quick fix once I realized the hanging cable....did you remove the battery recently?

Very good point !
I guess I should always include this in my list of probabilities.... I use to do so in the past, but over time, I kind of assume that the basics have been checked before. As I age, I am loosing patience with poster who do not check basic stuff before asking for help - they should go to dealer ;-)
__________________
~~~~~~~~~~~~~~~~~~~~~~~~~~
Jean (Montreal, CANADA)
K1200RS (2002 IceBlue/Red - 95,000 miles)
~~~~~~~~~~~~~~~~~~~~~~~~~~
K1200RS parts for sale here:
http://www.i-bmw.com/classifieds/sho...500&ppuser=144
++++++++++++++++++++++++++
Reply With Quote
The following (2) I-BMW members 'like', thank -or- are 'shouting out' to 'sailor' for this post:
  #6  
Old 08-15-2018, 10:14 PM
Beech's Avatar
Beech Beech is online now
I-BMW Rider of the Year 2016
Post: 6,617 Thanks: 1,643
Thanked 1,565 Times in 1,197 Posts
 
Join Date: Nov 2003
Location: mount vernon, WA usa
Re: '98 K1200RS speedometer failure

It is hard to remember there are always new folks.
__________________
Beech Arriba, Abajo, Al Centro, Adentro
Mount Vernon Cannon Works
K1300S
S1000R
I need a Vespa
I change your tires, you buy them on the web, I do the work $40, trying to keep riders on the road.
Reply With Quote
Reply


Thread Tools..
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads (a database pull of similar subject matter)
Thread Thread Starter Forum Replies Last Post
98 K1200rs no power Vito "KRS/GT" Technical Q&A 13 10-09-2016 05:32 AM
R-Sport Speedometer and Brake Failure Travis in Wa "K12S/KR" Technical Q&A 17 04-01-2015 11:59 PM
2002 K1200RS Rear Brake Failure outlaw "KRS/GT" Technical Q&A 12 09-10-2009 08:28 PM
K1200RS rear drive issue (pending failure?) FastEddieb "KRS/GT" Technical Q&A 25 07-12-2009 12:47 PM
No ABS Reset on 98 K1200RS? tholly "KRS/GT" Technical Q&A 14 07-09-2008 10:27 AM


All times are GMT -4. The time now is 07:28 AM.


I-BMW.com is via vBulletin Version 3.5.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 1998 - 2018, I-BMW.com LLC .
Page generated in 0.58656 seconds with 17 queries