I-BMW.com I-BMW.com

Welcome to the I-BMW.com forums! - You're currently viewing as a limited access guest. By joining our free member supported community, you'll gain access to post/ reply, communicate privately with other members (PM), or globally via "real time chat", respond to polls, upload photos, post classifieds etc. Membership is fast so, Register @ the Ultimate Sport Touring Portal!
Should you not receive an email with activation link, check your SPAM settings or please contact us and include the ID/ email address you registered with.

Go Back   I-BMW.com > BMW K-1200 Series Motorcycles > K1200S > "K12S/KR" Technical Q&A
User Name
Password
Home Register Gallery Classifieds FAQ Members List Calendar Donate Mark Forums Read

"K12S/KR" Technical Q&A K1200S/R Technical Questions/Answers

Vendor Sign Up | Want to see your name in neon blue? | Want a neat reflective sticker for your ride?!

Reply
 
Thread Tools.. Display Modes
  #1  
Old 06-06-2017, 11:13 PM
JEBZ's Avatar
JEBZ JEBZ is offline
Entering the on-ramp
Post: 8 Thanks: 2
Thanked 1 Time in 1 Post
 
Join Date: Aug 2016
Location: Letsitele, SA South Africa
Send a message via Skype™ to JEBZ
Right hand side turn signals not working at all

Hi there, my 2006 k1200s decided it was due time to give me something to wonder about. The right hand side turn signal has decided to stop working.....totally. Can it be the button not working, that is where my thinking lies, as two days ago it worked on and of at times.
Anyone had such problems or know of this....
Reply With Quote
  #2  
Old 06-07-2017, 12:31 AM
Beech's Avatar
Beech Beech is offline
I-BMW Rider of the Year 2016
Post: 6,601 Thanks: 1,636
Thanked 1,559 Times in 1,191 Posts
 
Join Date: Nov 2003
Location: mount vernon, WA usa
Re: Right hand side turn signals not working at all

Well probably it is the switch. Posts in the past have had bikes with the switch fail. Also the computer the switch uses, forgot the name of it. But first look over your wiring and connectors. There have been cases of wire harness too tied too tight to the frame and wire broken inside the insulation. Yours seems like a simple problem but in reality it can be quite difficult. Of course you have measured for voltage at the lamp housing, checked the bulbs with an ohm meter and all the basics. (?)
__________________
Beech Arriba, Abajo, Al Centro, Adentro
Mount Vernon Cannon Works
K1300S
S1000R
I need a Vespa
I change your tires, you buy them on the web, I do the work $40, trying to keep riders on the road.
Reply With Quote
  #3  
Old 06-07-2017, 06:37 AM
paulmogs paulmogs is offline
Site Contributor
Post: 2,243 Thanks: 1,535
Thanked 2,232 Times in 1,077 Posts
 
Join Date: Oct 2014
Re: Right hand side turn signals not working at all

To reduce guessing, may have to plug a GS911 into the system & check for indicator operation.

You can operate horn, indicators thru computer, to check these circuits.

May not help....but, do the hazard lights work? Key on, hit L & R indicator buttons at same time.
Reply With Quote
The following (2) I-BMW members 'like', thank -or- are 'shouting out' to 'paulmogs' for this post:
  #4  
Old 06-07-2017, 08:48 PM
kenthegrass's Avatar
kenthegrass kenthegrass is offline
The Cleaner - I solve problems
Post: 2,094 Thanks: 1,278
Thanked 534 Times in 334 Posts
 
Join Date: Jun 2006
Location: Baneberry, TN USA
Re: Right hand side turn signals not working at all

Hopefully it's NOT the dreaded ZFE packing it...
__________________
A product of "onfortunate upbringing..."


'05 K12 S - KIA 6/21/11
'04 Ducati 999 - traded
'07 R1200 GS - sold
'99 R1100 S - traded
'05 K12 S - traded
'11 K13 S Magma Red - traded
'16 R1200 GSW Triple Black - traded
'16 K13 S MotorSport
Reply With Quote
  #5  
Old 06-13-2017, 10:03 AM
JEBZ's Avatar
JEBZ JEBZ is offline
Entering the on-ramp
Post: 8 Thanks: 2
Thanked 1 Time in 1 Post
 
Join Date: Aug 2016
Location: Letsitele, SA South Africa
Send a message via Skype™ to JEBZ
Re: Right hand side turn signals not working at all

Ok, so this is what is happening ......on and off
Sometimes it works, sometimes I have to push left flicker cancel left flicker and then right flicker works. It seems that I first have to use something else before the right flicker will work. Everything else works. I took the bike over from my father, he cant ride anymore due to bad eye sight, it was standing for about three months.
Reply With Quote
  #6  
Old 06-13-2017, 09:47 PM
Thunderhead308's Avatar
Thunderhead308 Thunderhead308 is offline
Shooting the gap
Post: 235 Thanks: 166
Thanked 59 Times in 37 Posts
 
Join Date: Aug 2016
Location: San Antonio, Tx United State
Re: Right hand side turn signals not working at all

I had this problem as well. I thought it might be the unit, in the black housing on the right bar. It was cold here when it started so i thought maybe it was contracted and didn't work that way. It got hot again, over 100F today and worked fine. You know expansion and contraction. I am hoping it lasts until i can get my regristration, because the turn indicator needs to work to pass. After that, it can die.

I read on this forum that a symptom such as this may be due to the circuitry and the electrical components for the turn indicator, as i did have fo play with the left canceling it and the throttle and thunking on it while riding. This unit i read can be in the $400USD range and that is excluding labor
__________________
"Keep your wits about you, cause I'm gonna keep mine"-Tom Horn
"Mister, you can't have no idea how little I care"-Monte Walsh
Reply With Quote
  #7  
Old 11-07-2017, 06:00 AM
JEBZ's Avatar
JEBZ JEBZ is offline
Entering the on-ramp
Post: 8 Thanks: 2
Thanked 1 Time in 1 Post
 
Join Date: Aug 2016
Location: Letsitele, SA South Africa
Send a message via Skype™ to JEBZ
Re: Right hand side turn signals not working at all

Howzit Buds, so..... the problem is now back, and it seems permanent now. I have stripped everything and could not find fault. My next stop is a dealership.

My rear tyre needs replacement, current tyre is a Pirelli Angel gt...... what a awesome tyre.... The size 190/55R17. I got a easy 14000kms on it, most of was commuting to work and back (70km per day). I see some countries giving the rear tyre size as 190/50R17. So what should it be?
__________________
JESUS IS LORD, spread the WORD, because everybody has the right to say....

"THANK YOU JESUS"
Reply With Quote
  #8  
Old 11-07-2017, 08:20 AM
mcchoc's Avatar
mcchoc mcchoc is offline
Twisted Wrister
Post: 677 Thanks: 188
Thanked 124 Times in 84 Posts
 
Join Date: Mar 2006
Location: East Riding of Yorkshire UK, England
Re: Right hand side turn signals not working at all

I seem to remember my K1200S had a 190/50-17 - but my K1300S has 190/55-17.
__________________
The Warthog
2014 K1300S MS (until it's time for that invalid scooter)
1997 K1200RS (old faithful)
History:
Yamaha RD250 (x2)
Yamaha XS750
Kawasaki Z1000 (x3)
Honda Blackbird
Yamaha FJ1200 (x2)
BMW K1200S
Reply With Quote
  #9  
Old 11-07-2017, 11:35 AM
Beech's Avatar
Beech Beech is offline
I-BMW Rider of the Year 2016
Post: 6,601 Thanks: 1,636
Thanked 1,559 Times in 1,191 Posts
 
Join Date: Nov 2003
Location: mount vernon, WA usa
Re: Right hand side turn signals not working at all

Mcchoc is correct. 190/50 for the K12S, goes to the 190/55 for the K13S
__________________
Beech Arriba, Abajo, Al Centro, Adentro
Mount Vernon Cannon Works
K1300S
S1000R
I need a Vespa
I change your tires, you buy them on the web, I do the work $40, trying to keep riders on the road.
Reply With Quote
  #10  
Old 11-08-2017, 01:49 AM
JEBZ's Avatar
JEBZ JEBZ is offline
Entering the on-ramp
Post: 8 Thanks: 2
Thanked 1 Time in 1 Post
 
Join Date: Aug 2016
Location: Letsitele, SA South Africa
Send a message via Skype™ to JEBZ
Re: Right hand side turn signals not working at all

Thanx Buds, I was figuring on putting a 50 on ...
__________________
JESUS IS LORD, spread the WORD, because everybody has the right to say....

"THANK YOU JESUS"
Reply With Quote
Reply


Thread Tools..
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads (a database pull of similar subject matter)
Thread Thread Starter Forum Replies Last Post
One Indicator (turn signal) not working??? Goandays "K13S/R" Technical Q&A 1 05-17-2014 09:19 PM
Oh oh - K1200RS kill switch / turn cancel not working BlueBM "KRS/GT" Technical Q&A 15 04-07-2008 10:59 AM
R1200RT Self cancelling indicators (turn signals). Quattro BMW R-Series 1 11-04-2007 09:13 AM
clear lenses for front turn signals???? SilverRT "K12GT" Accessories 8 08-05-2006 12:46 PM
Self-cancelling turn signals on '98 RS? Paughco "KRS/GT" Technical Q&A 2 06-25-2006 01:50 PM


All times are GMT -4. The time now is 08:15 AM.


I-BMW.com is via vBulletin Version 3.5.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 1998 - 2018, I-BMW.com LLC .
Page generated in 0.51152 seconds with 15 queries